Is ASPluris Windows 10 compatible?

You are here:
< Back

Yes. ASPluris is compatible with Windows Vista and later desktop operating systems, and Windows Server 2008 and later server operating systems.

ASPluris is not compatible with Windows XP or earlier, or Server 2003 or earlier.